Excessive Rate Limiting [Global]
Incident Report for JEM
Resolved
This incident has been resolved.
Posted Nov 14, 2023 - 19:53 GMT
Identified
JEM services, with a focus on VerifiedHandles.org, are currently encountering 429 "Too Many Requests" errors when accessed by regular users. We are actively collaborating with our DDoS protection service to resolve this issue.
Posted Oct 01, 2023 - 16:22 BST
This incident affected: Backend API (Virginia NodeJS Hack-Check v2023.2.6 cache server, Virginia NodeJS Block-Check v2023.2.2 cache server, API) and Frontend (VerifiedHandles.org, Verified Handles Database).